Philippsen's Blog

Everyday findings in my world of .net and related stuff

Posts Tagged ‘Microsoft.DynamicsBusinessConnectorNet.dll’

Business Connector isssues

Posted by Torben M. Philippsen on January 27, 2012

In a webservice I am using the Microsoft.DynamicsBusinessConnectorNet.dll. Today the webservice stopped working giving the error:

Could not load file or assembly ‘Microsoft.Dynamics.BusinessConnectorNet’

This was quite strange since the service was working yesterday. The reason to the error turned out to be a new deployment of a new webapplication to the IIS. This particular webapplication required the IIS to run in 64 bit mode and therefore this was changed. The Microsoft.DynamicsBusinessConnectorNet.dll that I was using was the 32bit version – which ofcourse was the cause of the error.

The solultion was to enable the application pool to allow 32 bit application. This is done by:

  • Right clicking the application pool and selecting “advanced setting”
  • Set the “enable 32-bit applicataions” to true

Here’s a screendump:

Enable 32 bit applicaations in IIS

Enable 32 bit applicaations in IIS

 

Update 2012-11-27: When enabling 32 bit applications on IIS6 I recently encountered that one need to run aspnet_regiis.exe in order to register the 32 bit version of the .net framework – otherwise I received a “servive not available” message

Update 2015-07-10: Recently we ran into another issue when running OWA on the same IIS. We found this solution very helpful: http://www.mosmar.com.au/chris-blog/2011/3/15/taking-care-of-bitness-or-how-to-run-a-32-bit-app-with-owa-2.html

Posted in IIS | Tagged: , , , | Comments Off on Business Connector isssues

 
%d bloggers like this: